HOME SHARED LETTERS RATINGS MY PLANET COMMUNITIES MISSION SIGN UP!
Shared Letters

Join and browse our exclusive open discussion forums and talk about whatever you like.

Channels
» The Suggestion Box
» Company Responses
» PFB Feedback Line
» Consumer Podcasts
» Mommy Talk & Daddy Dialogue ™
» Shared Letters


Newsletter

Sign up for PlanetFeedback's "Consumer Café" email newsletter!





50v500 hdtv lcd bad light engine poor customer service no solution

Posted Thu February 22, 2007 11:52 pm, by Robert S. written to Hitachi Home Electronics America

Write a Letter to this Company


i paid several thousands of dollars for a 50v500 50" lcd projection hdtv a couple years ago. Now I find out there are hundreds of users that have problems with this tv. Mine has a blue blob on the screen that can't be fixed. According to my google searches and the av forums, it appears its the light engine. So, for some people, Hitachi is sending out a replacement light engine, but i still have to pay hundreds of dollars to get it installed. Seems like this should be a product recall issue, and should be repaired for free. It would be the right thing for Hitachi to do. Please advise.

Send a tech out to repair my tv at Hitachi's cost, as if it were under warranty or a product recall issue.


Reply



Log In/Create an account | 5 comments
     Add to your del.icio.us  del.icio.us    Digg this story  Digg this  
PlanetFeedback Comments are subject to strict terms and conditions. We reserve the right to deny site membership privileges to any individuals acting inappropriately.
by GUMBY Posted Mon December 24, 2007 @ 9:38 PM

WHAT DID THEY EVER RESPOND TO YOU WITH AFTER THIS REQUEST????????????

Reply


Re: 50v500 hdtv lcd bad light engine by Lee H. Mon February 26, 2007 @ 5:12 AM
by Candyman68 Posted Wed March 7, 2007 @ 9:06 PM

i dont agree.

its a faulty defective product from the manufacturer.
There should be a recall on these tv's

AND the service centers know they aren;t going to make any money on
the part, so they have jacked up the installation cost to over $500!

what a scam!


Reply

50v500 bad light engine by Hudracing Thu June 28, 2007 @ 10:09 PM

Agree by GUMBY Tue December 25, 2007 @ 8:56 PM




Home | Shared Letters | Ratings | Login | Communities | Categories | RSS | Contact Us | Terms & Conditions | Privacy Policy | FAQ
Copyright 2014 © All Rights Reserved PlanetFeedback.com | Web by Cicada