HOME SHARED LETTERS RATINGS MY PLANET COMMUNITIES MISSION SIGN UP!
Shared Letters

Join and browse our exclusive open discussion forums and talk about whatever you like.

Channels
» The Suggestion Box
» Company Responses
» PFB Feedback Line
» Consumer Podcasts
» Mommy Talk & Daddy Dialogue ™
» Shared Letters


Newsletter

Sign up for PlanetFeedback's "Consumer Café" email newsletter!





old Tracfone works THE NEW ONE DOESN'T

Posted Tue October 8, 2013 12:00 pm, by . written to Tracfone Wireless, Inc

Write a Letter to this Company  |  Rate this Company


I have had a Tracfone flip phone for at least 4 years and been satisfied with it -- although have never been able to do any web stuff. So, I bought a new LG 840g and at first I could not even make a call. Probably because I cannot get a signal!!!! Called the not-in-the-US customer service. They hade me input several screens of codes. Okay I can now make calls -- when I'm in an area with a signal.
(remember my old Tracfone gets a signal at my home -- but NOT the new phone). NOW I cannot enter even one "contact". When I hit the ADD button it tells me I have no contacts--yep that bright...I'm trying to ADD THEM. I cannot get the go to URL to work!!! Basically my OLD flip phone is better than this new phone@!!! SO FRUSTRATED--been ripped off for the cost of the phone and the 60 minute card!

GET ME A PHONE THAT WORKS IN THE AREA I LIVE IN!


Reply


Home | Shared Letters | Ratings | Login | Communities | Categories | RSS | Contact Us | Terms & Conditions | Privacy Policy | FAQ
Copyright 2014 © All Rights Reserved PlanetFeedback.com | Web by Cicada